Welcome to MSSQL Forum!
MSSQL Forum - Discussions about Microsoft SQL Server

You are currently viewing our community forums as a guest user. Sign up or
Having an account grants you additional privileges, such as creating and participating in discussions.

A list of Operating System Errors

Discussion in 'General' started by Peter Schmitz, Oct 1, 2012.

  1. Peter Schmitz

    Peter Schmitz Administrator Staff Member

    At times, when dealing with SQL Server Administration, you will encounter error messages like the one I encountered today:

    Code (text):
    Msg 5149, Level 16, State 3, Line 1
     MODIFY FILE encountered operating system error 112 (failed to retrieve text for this error. Reason: 15105) while attempting to expand the physical file '<filename>'.

    The "Failed to retrieve text for this error" is quite annoying, and I figured I would post a list of the Operating System Errors here, as a quick reference.

    0The operation completed successfully.ERROR_SUCCESS
    1Incorrect function.ERROR_INVALID_FUNCTION
    2The system cannot find the file specified.ERROR_FILE_NOT_FOUND
    3The system cannot find the path specified.ERROR_PATH_NOT_FOUND
    4The system cannot open the file.ERROR_TOO_MANY_OPEN_FILES
    5Access is denied.ERROR_ACCESS_DENIED
    6The handle is invalid.ERROR_INVALID_HANDLE
    7The storage control blocks were destroyed.ERROR_ARENA_TRASHED
    8Not enough storage is available to process this command.ERROR_NOT_ENOUGH_MEMORY
    9The storage control block address is invalid.ERROR_INVALID_BLOCK
    10The environment is incorrect.ERROR_BAD_ENVIRONMENT
    11An attempt was made to load a program with an incorrect format.ERROR_BAD_FORMAT
    12The access code is invalid.ERROR_INVALID_ACCESS
    13The data is invalid.ERROR_INVALID_DATA
    14Not enough storage is available to complete this operation.ERROR_OUTOFMEMORY
    15The system cannot find the drive specified.ERROR_INVALID_DRIVE
    16The directory cannot be removed.ERROR_CURRENT_DIRECTORY
    17The system cannot move the file to a different disk drive.ERROR_NOT_SAME_DEVICE
    18There are no more files.ERROR_NO_MORE_FILES
    19The media is write protected.ERROR_WRITE_PROTECT
    20The system cannot find the device specified.ERROR_BAD_UNIT
    21The device is not ready.ERROR_NOT_READY
    22The device does not recognize the command.ERROR_BAD_COMMAND
    23Data error (cyclic redundancy check).ERROR_CRC
    24The program issued a command but the command length is incorrect.ERROR_BAD_LENGTH
    25The drive cannot locate a specific area or track on the disk.ERROR_SEEK
    26The specified disk or diskette cannot be accessed.ERROR_NOT_DOS_DISK
    27The drive cannot find the sector requested.ERROR_SECTOR_NOT_FOUND
    28The printer is out of paper.ERROR_OUT_OF_PAPER
    29The system cannot write to the specified device.ERROR_WRITE_FAULT
    30The system cannot read from the specified device.ERROR_READ_FAULT
    31A device attached to the system is not functioning.ERROR_GEN_FAILURE
    32The process cannot access the file because it is being used byanother process.ERROR_SHARING_VIOLATION
    33The process cannot access the file because another process has lockeda portion of the file.ERROR_LOCK_VIOLATION
    34The wrong diskette is in the drive. Insert %2 (Volume Serial Number:%3) into drive %1.ERROR_WRONG_DISK
    36Too many files opened for sharing.ERROR_SHARING_BUFFER_EXCEEDED
    38Reached the end of the file.ERROR_HANDLE_EOF
    39The disk is full.ERROR_HANDLE_DISK_FULL
    50The network request is not supported.ERROR_NOT_SUPPORTED
    51The remote computer is not available.ERROR_REM_NOT_LIST
    52A duplicate name exists on the network.ERROR_DUP_NAME
    53The network path was not found.ERROR_BAD_NETPATH
    54The network is busy.ERROR_NETWORK_BUSY
    55The specified network resource or device is no longer available.ERROR_DEV_NOT_EXIST
    56The network BIOS command limit has been reached.ERROR_TOO_MANY_CMDS
    57A network adapter hardware error occurred.ERROR_ADAP_HDW_ERR
    58The specified server cannot perform the requested operation.ERROR_BAD_NET_RESP
    59An unexpected network error occurred.ERROR_UNEXP_NET_ERR
    60The remote adapter is not compatible.ERROR_BAD_REM_ADAP
    61The printer queue is full.ERROR_PRINTQ_FULL
    62Space to store the file waiting to be printed is not available on theserver.ERROR_NO_SPOOL_SPACE
    63Your file waiting to be printed was deleted.ERROR_PRINT_CANCELLED
    64The specified network name is no longer available.ERROR_NETNAME_DELETED
    65Network access is denied.ERROR_NETWORK_ACCESS_DENIED
    66The network resource type is not correct.ERROR_BAD_DEV_TYPE
    67The network name cannot be found.ERROR_BAD_NET_NAME
    68The name limit for the local computer network adapter card wasexceeded.ERROR_TOO_MANY_NAMES
    69The network BIOS session limit was exceeded.ERROR_TOO_MANY_SESS
    70The remote server has been paused or is in the process of beingstarted.ERROR_SHARING_PAUSED
    71No more connections can be made to this remote computer at this timebecause there are already as many connections as the computer can accept.ERROR_REQ_NOT_ACCEP
    72The specified printer or disk device has been paused.ERROR_REDIR_PAUSED
    80The file exists.ERROR_FILE_EXISTS
    82The directory or file cannot be created.ERROR_CANNOT_MAKE
    83Fail on INT 24.ERROR_FAIL_I24
    84Storage to process this request is not available.ERROR_OUT_OF_STRUCTURES
    85The local device name is already in use.ERROR_ALREADY_ASSIGNED
    86The specified network password is not correct.ERROR_INVALID_PASSWORD
    87The parameter is incorrect.ERROR_INVALID_PARAMETER
    88A write fault occurred on the network.ERROR_NET_WRITE_FAULT
    89The system cannot start another process at this time.ERROR_NO_PROC_SLOTS
    100Cannot create another system semaphore.ERROR_TOO_MANY_SEMAPHORES
    101The exclusive semaphore is owned by another process.ERROR_EXCL_SEM_ALREADY_OWNED
    102The semaphore is set and cannot be closed.ERROR_SEM_IS_SET
    103The semaphore cannot be set again.ERROR_TOO_MANY_SEM_REQUESTS
    104Cannot request exclusive semaphores at interrupt time.ERROR_INVALID_AT_INTERRUPT_TIME
    105The previous ownership of this semaphore has ended.ERROR_SEM_OWNER_DIED
    106Insert the diskette for drive %1.ERROR_SEM_USER_LIMIT
    107The program stopped because an alternate diskette was not inserted.ERROR_DISK_CHANGE
    108The disk is in use or locked by another process.ERROR_DRIVE_LOCKED
    109The pipe has been ended.ERROR_BROKEN_PIPE
    110The system cannot open the device or file specified.ERROR_OPEN_FAILED
    111The file name is too long.ERROR_BUFFER_OVERFLOW
    112There is not enough space on the disk.ERROR_DISK_FULL
    113No more internal file identifiers available.ERROR_NO_MORE_SEARCH_HANDLES
    114The target internal file identifier is incorrect.ERROR_INVALID_TARGET_HANDLE
    117The IOCTL call made by the application program is not correct.ERROR_INVALID_CATEGORY
    118The verify-on-write switch parameter value is not correct.ERROR_INVALID_VERIFY_SWITCH
    119The system does not support the command requested.ERROR_BAD_DRIVER_LEVEL
    120This function is not valid on this platform.ERROR_CALL_NOT_IMPLEMENTED
    121The semaphore time-out period has expired.ERROR_SEM_TIMEOUT
    122The data area passed to a system call is too small.ERROR_INSUFFICIENT_BUFFER
    123The filename, directory name, or volume label syntax is incorrect.ERROR_INVALID_NAME
    124The system call level is not correct.ERROR_INVALID_LEVEL
    125The disk has no volume label.ERROR_NO_VOLUME_LABEL
    126The specified module could not be found.ERROR_MOD_NOT_FOUND
    127The specified procedure could not be found.ERROR_PROC_NOT_FOUND
    128There are no child processes to wait for.ERROR_WAIT_NO_CHILDREN
    129The %1 application cannot be run in Windows NT mode.ERROR_CHILD_NOT_COMPLETE
    130Attempt to use a file handle to an open disk partition for anoperation other than raw disk I/O.ERROR_DIRECT_ACCESS_HANDLE
    131An attempt was made to move the file pointer before the beginning ofthe file.ERROR_NEGATIVE_SEEK
    132The file pointer cannot be set on the specified device or file.ERROR_SEEK_ON_DEVICE
    133A JOIN or SUBST command cannot be used for a drive that containspreviously joined drives.ERROR_IS_JOIN_TARGET
    134An attempt was made to use a JOIN or SUBST command on a drive thathas already been joined.ERROR_IS_JOINED
    135An attempt was made to use a JOIN or SUBST command on a drive thathas already been substituted.ERROR_IS_SUBSTED
    136The system tried to delete the JOIN of a drive that is not joined.ERROR_NOT_JOINED
    137The system tried to delete the substitution of a drive that is notsubstituted.ERROR_NOT_SUBSTED
    138The system tried to join a drive to a directory on a joined drive.ERROR_JOIN_TO_JOIN
    139The system tried to substitute a drive to a directory on asubstituted drive.ERROR_SUBST_TO_SUBST
    140The system tried to join a drive to a directory on a substituteddrive.ERROR_JOIN_TO_SUBST
    141The system tried to SUBST a drive to a directory on a joined drive.ERROR_SUBST_TO_JOIN
    142The system cannot perform a JOIN or SUBST at this time.ERROR_BUSY_DRIVE
    143The system cannot join or substitute a drive to or for a directory onthe same drive.ERROR_SAME_DRIVE
    144The directory is not a subdirectory of the root directory.ERROR_DIR_NOT_ROOT
    145The directory is not empty.ERROR_DIR_NOT_EMPTY
    146The path specified is being used in a substitute.ERROR_IS_SUBST_PATH
    147Not enough resources are available to process this command.ERROR_IS_JOIN_PATH
    148The path specified cannot be used at this time.ERROR_PATH_BUSY
    149An attempt was made to join or substitute a drive for which adirectory on the drive is the target of a previous substitute.ERROR_IS_SUBST_TARGET
    150System trace information was not specified in your CONFIG.SYS file,or tracing is disallowed.ERROR_SYSTEM_TRACE
    151The number of specified semaphore events for DosMuxSemWait is notcorrect.ERROR_INVALID_EVENT_COUNT
    152DosMuxSemWait did not execute; too many semaphores are already set.ERROR_TOO_MANY_MUXWAITERS
    153The DosMuxSemWait list is not correct.ERROR_INVALID_LIST_FORMAT
    154The volume label you entered exceeds the label character limit of thetarget file system.ERROR_LABEL_TOO_LONG
    155Cannot create another thread.ERROR_TOO_MANY_TCBS
    156The recipient process has refused the signal.ERROR_SIGNAL_REFUSED
    157The segment is already discarded and cannot be locked.ERROR_DISCARDED
    158The segment is already unlocked.ERROR_NOT_LOCKED
    159The address for the thread ID is not correct.ERROR_BAD_THREADID_ADDR
    160The argument string passed to DosExecPgm is not correct.ERROR_BAD_ARGUMENTS
    161The specified path is invalid.ERROR_BAD_PATHNAME
    162A signal is already pending.ERROR_SIGNAL_PENDING
    164No more threads can be created in the system.ERROR_MAX_THRDS_REACHED
    167Unable to lock a region of a file.ERROR_LOCK_FAILED
    170The requested resource is in use.ERROR_BUSY
    173A lock request was not outstanding for the supplied cancel region.ERROR_CANCEL_VIOLATION
    174The file system does not support atomic changes to the lock type.ERROR_ATOMIC_LOCKS_NOT_SUPPORTED
    180The system detected a segment number that was not correct.ERROR_INVALID_SEGMENT_NUMBER
    182The operating system cannot run %1.ERROR_INVALID_ORDINAL
    183Cannot create a file when that file already exists.ERROR_ALREADY_EXISTS
    186The flag passed is not correct.ERROR_INVALID_FLAG_NUMBER
    187The specified system semaphore name was not found.ERROR_SEM_NOT_FOUND
    188The operating system cannot run %1.ERROR_INVALID_STARTING_CODESEG
    189The operating system cannot run %1.ERROR_INVALID_STACKSEG
    190The operating system cannot run %1.ERROR_INVALID_MODULETYPE
    191Cannot run %1 in Windows NT mode.ERROR_INVALID_EXE_SIGNATURE
    192The operating system cannot run %1.ERROR_EXE_MARKED_INVALID
    193Is not a valid application.ERROR_BAD_EXE_FORMAT
    194The operating system cannot run %1.ERROR_ITERATED_DATA_EXCEEDS_64k
    195The operating system cannot run %1.ERROR_INVALID_MINALLOCSIZE
    196The operating system cannot run this application program.ERROR_DYNLINK_FROM_INVALID_RING
    197The operating system is not presently configured to run thisapplication.ERROR_IOPL_NOT_ENABLED
    198The operating system cannot run %1.ERROR_INVALID_SEGDPL
    199The operating system cannot run this application program.ERROR_AUTODATASEG_EXCEEDS_64k
    200The code segment cannot be greater than or equal to 64K.ERROR_RING2SEG_MUST_BE_MOVABLE
    201The operating system cannot run %1.ERROR_RELOC_CHAIN_XEEDS_SEGLIM
    202The operating system cannot run %1.ERROR_INFLOOP_IN_RELOC_CHAIN
    203The system could not find the environment option that was entered.ERROR_ENVVAR_NOT_FOUND
    205No process in the command subtree has a signal handler.ERROR_NO_SIGNAL_SENT
    206The filename or extension is too long.ERROR_FILENAME_EXCED_RANGE
    207The ring 2 stack is in use.ERROR_RING2_STACK_IN_USE
    208The global filename characters, * or ?, are entered incorrectly ortoo many global filename characters are specified.ERROR_META_EXPANSION_TOO_LONG
    209The signal being posted is not correct.ERROR_INVALID_SIGNAL_NUMBER
    210The signal handler cannot be set.ERROR_THREAD_1_INACTIVE
    212The segment is locked and cannot be reallocated.ERROR_LOCKED
    214Too many dynamic-link modules are attached to this program ordynamic-link module.ERROR_TOO_MANY_MODULES
    215Can't nest calls to LoadModule.ERROR_NESTING_NOT_ALLOWED
    216The image file %1 is valid, but is for a machine type other than thecurrent machine.ERROR_EXE_MACHINE_TYPE_MISMATCH
    230The pipe state is invalid.ERROR_BAD_PIPE
    231All pipe instances are busy.ERROR_PIPE_BUSY
    232The pipe is being closed.ERROR_NO_DATA
    233No process is on the other end of the pipe.ERROR_PIPE_NOT_CONNECTED
    234More data is available.ERROR_MORE_DATA
    240The session was canceled.ERROR_VC_DISCONNECTED
    254The specified extended attribute name was invalid.ERROR_INVALID_EA_NAME
    255The extended attributes are inconsistent.ERROR_EA_LIST_INCONSISTENT
    259No more data is available.ERROR_NO_MORE_ITEMS
    266The copy functions cannot be used.ERROR_CANNOT_COPY
    267The directory name is invalid.ERROR_DIRECTORY
    275The extended attributes did not fit in the buffer.ERROR_EAS_DIDNT_FIT
    276The extended attribute file on the mounted file system is corrupt.ERROR_EA_FILE_CORRUPT
    277The extended attribute table file is full.ERROR_EA_TABLE_FULL
    278The specified extended attribute handle is invalid.ERROR_INVALID_EA_HANDLE
    282The mounted file system does not support extended attributes.ERROR_EAS_NOT_SUPPORTED
    288Attempt to release mutex not owned by caller.ERROR_NOT_OWNER
    298Too many posts were made to a semaphore.ERROR_TOO_MANY_POSTS
    299Only part of a ReadProcessMemory or WriteProcessMemory request was completed.ERROR_PARTIAL_COPY
    317The system cannot find message text for message number 0x%1 in themessage file for %2.ERROR_MR_MID_NOT_FOUND
    487Attempt to access invalid address.ERROR_INVALID_ADDRESS
    534Arithmetic result exceeded 32 bits.ERROR_ARITHMETIC_OVERFLOW
    535There is a process on other end of the pipe.ERROR_PIPE_CONNECTED
    536Waiting for a process to open the other end of the pipe.ERROR_PIPE_LISTENING
    994Access to the extended attribute was denied.ERROR_EA_ACCESS_DENIED
    995The I/O operation has been aborted because of either a thread exit oran application request.ERROR_OPERATION_ABORTED
    996Overlapped I/O event is not in a signaled state.ERROR_IO_INCOMPLETE
    997Overlapped I/O operation is in progress.ERROR_IO_PENDING
    998Invalid access to memory location.ERROR_NOACCESS
    999Error performing inpage operation.ERROR_SWAPERROR
    1001Recursion too deep; the stack overflowed.ERROR_STACK_OVERFLOW
    1002The window cannot act on the sent message.ERROR_INVALID_MESSAGE
    1003Cannot complete this function.ERROR_CAN_NOT_COMPLETE
    1004Invalid flags.ERROR_INVALID_FLAGS
    1005The volume does not contain a recognized file system. Please makesure that all required file system drivers are loaded and that the volume is notcorrupted.ERROR_UNRECOGNIZED_VOLUME
    1006The volume for a file has been externally altered so that the openedfile is no longer valid.ERROR_FILE_INVALID
    1007The requested operation cannot be performed in full-screen mode.ERROR_FULLSCREEN_MODE
    1008An attempt was made to reference a token that does not exist.ERROR_NO_TOKEN
    1009The configuration registry database is corrupt.ERROR_BADDB
    1010The configuration registry key is invalid.ERROR_BADKEY
    1011The configuration registry key could not be opened.ERROR_CANTOPEN
    1012The configuration registry key could not be read.ERROR_CANTREAD
    1013The configuration registry key could not be written.ERROR_CANTWRITE
    1014One of the files in the registry database had to be recovered by useof a log or alternate copy. The recovery was successful.ERROR_REGISTRY_RECOVERED
    1015The registry is corrupted. The structure of one of the files thatcontains registry data is corrupted, or the system's image of the file in memory iscorrupted, or the file could not be recovered because the alternate copy or log was absentor corrupted.ERROR_REGISTRY_CORRUPT
    1016An I/O operation initiated by the registry failed unrecoverably. Theregistry could not read in, or write out, or flush, one of the files that contain thesystem's image of the registry.ERROR_REGISTRY_IO_FAILED
    1017The system has attempted to load or restore a file into the registry,but the specified file is not in a registry file format.ERROR_NOT_REGISTRY_FILE
    1018Illegal operation attempted on a registry key that has been markedfor deletion.ERROR_KEY_DELETED
    1019System could not allocate the required space in a registry log.ERROR_NO_LOG_SPACE
    1020Cannot create a symbolic link in a registry key that already hassubkeys or values.ERROR_KEY_HAS_CHILDREN
    1021Cannot create a stable subkey under a volatile parent key.ERROR_CHILD_MUST_BE_VOLATILE
    1022A notify change request is being completed and the information is notbeing returned in the caller's buffer. The caller now needs to enumerate the files to findthe changes.ERROR_NOTIFY_ENUM_DIR
    1051A stop control has been sent to a service that other running servicesare dependent on.ERROR_DEPENDENT_SERVICES_RUNNING
    1052The requested control is not valid for this service.ERROR_INVALID_SERVICE_CONTROL
    1053The service did not respond to the start or control request in atimely fashion.ERROR_SERVICE_REQUEST_TIMEOUT
    1054A thread could not be created for the service.ERROR_SERVICE_NO_THREAD
    1055The service database is locked.ERROR_SERVICE_DATABASE_LOCKED
    1056An instance of the service is already running.ERROR_SERVICE_ALREADY_RUNNING
    1057The account name is invalid or does not exist.ERROR_INVALID_SERVICE_ACCOUNT
    1058The specified service is disabled and cannot be started.ERROR_SERVICE_DISABLED
    1059Circular service dependency was specified.ERROR_CIRCULAR_DEPENDENCY
    1060The specified service does not exist as an installed service.ERROR_SERVICE_DOES_NOT_EXIST
    1061The service cannot accept control messages at this time.ERROR_SERVICE_CANNOT_ACCEPT_CTRL
    1062The service has not been started.ERROR_SERVICE_NOT_ACTIVE
    1063The service process could not connect to the service controller.ERROR_FAILED_SERVICE_CONTROLLER_CONNECT
    1064An exception occurred in the service when handling the controlrequest.ERROR_EXCEPTION_IN_SERVICE
    1065The database specified does not exist.ERROR_DATABASE_DOES_NOT_EXIST
    1066The service has returned a service-specific error code.ERROR_SERVICE_SPECIFIC_ERROR
    1067The process terminated unexpectedly.ERROR_PROCESS_ABORTED
    1068The dependency service or group failed to start.ERROR_SERVICE_DEPENDENCY_FAIL
    1069The service did not start due to a logon failure.ERROR_SERVICE_LOGON_FAILED
    1070After starting, the service hung in a start-pending state.ERROR_SERVICE_START_HANG
    1071The specified service database lock is invalid.ERROR_INVALID_SERVICE_LOCK
    1072The specified service has been marked for deletion.ERROR_SERVICE_MARKED_FOR_DELETE
    1073The specified service already exists.ERROR_SERVICE_EXISTS
    1074The system is currently running with the last-known-goodconfiguration.ERROR_ALREADY_RUNNING_LKG
    1075The dependency service does not exist or has been marked fordeletion.ERROR_SERVICE_DEPENDENCY_DELETED
    1076The current boot has already been accepted for use as thelast-known-good control set.ERROR_BOOT_ALREADY_ACCEPTED
    1077No attempts to start the service have been made since the last boot.ERROR_SERVICE_NEVER_STARTED
    1078The name is already in use as either a service name or a servicedisplay name.ERROR_DUPLICATE_SERVICE_NAME
    1079The account specified for this service is different from the accountspecified for other services running in the same process.ERROR_DIFFERENT_SERVICE_ACCOUNT
    1100The physical end of the tape has been reached.ERROR_END_OF_MEDIA
    1101A tape access reached a filemark.ERROR_FILEMARK_DETECTED
    1102The beginning of the tape or partition was encountered.ERROR_BEGINNING_OF_MEDIA
    1103A tape access reached the end of a set of files.ERROR_SETMARK_DETECTED
    1104No more data is on the tape.ERROR_NO_DATA_DETECTED
    1105Tape could not be partitioned.ERROR_PARTITION_FAILURE
    1106When accessing a new tape of a multivolume partition, the currentblock size is incorrect.ERROR_INVALID_BLOCK_LENGTH
    1107Tape partition information could not be found when loading a tape.ERROR_DEVICE_NOT_PARTITIONED
    1108Unable to lock the media eject mechanism.ERROR_UNABLE_TO_LOCK_MEDIA
    1109Unable to unload the media.ERROR_UNABLE_TO_UNLOAD_MEDIA
    1110The media in the drive may have changed.ERROR_MEDIA_CHANGED
    1111The I/O bus was reset.ERROR_BUS_RESET
    1112No media in drive.ERROR_NO_MEDIA_IN_DRIVE
    1113No mapping for the Unicode character exists in the target multibytecode page.ERROR_NO_UNICODE_TRANSLATION
    1114A dynamic link library (DLL) initialization routine failed.ERROR_DLL_INIT_FAILED
    1115A system shutdown is in progress.ERROR_SHUTDOWN_IN_PROGRESS
    1116Unable to abort the system shutdown because no shutdown was inprogress.ERROR_NO_SHUTDOWN_IN_PROGRESS
    1117The request could not be performed because of an I/O device error.ERROR_IO_DEVICE
    1118No serial device was successfully initialized. The serial driver willunload.ERROR_SERIAL_NO_DEVICE
    1119Unable to open a device that was sharing an interrupt request (IRQ)with other devices. At least one other device that uses that IRQ was already opened.ERROR_IRQ_BUSY
    1120A serial I/O operation was completed by another write to the serialport. The IOCTL_SERIAL_XOFF_COUNTER reached zero.)ERROR_MORE_WRITES
    1121A serial I/O operation completed because the time-out period expired.(The IOCTL_SERIAL_XOFF_COUNTER did not reach zero.)ERROR_COUNTER_TIMEOUT
    1122No ID address mark was found on the floppy disk.ERROR_FLOPPY_ID_MARK_NOT_FOUND
    1123Mismatch between the floppy disk sector ID field and the floppy diskcontroller track address.ERROR_FLOPPY_WRONG_CYLINDER
    1124The floppy disk controller reported an error that is not recognizedby the floppy disk driver.ERROR_FLOPPY_UNKNOWN_ERROR
    1125The floppy disk controller returned inconsistent results in itsregisters.ERROR_FLOPPY_BAD_REGISTERS
    1126While accessing the hard disk, a recalibrate operation failed, evenafter retries.ERROR_DISK_RECALIBRATE_FAILED
    1127While accessing the hard disk, a disk operation failed even afterretries.ERROR_DISK_OPERATION_FAILED
    1128While accessing the hard disk, a disk controller reset was needed,but even that failed.ERROR_DISK_RESET_FAILED
    1129Physical end of tape encountered.ERROR_EOM_OVERFLOW
    1130Not enough server storage is available to process this command.ERROR_NOT_ENOUGH_SERVER_MEMORY
    1131A potential deadlock condition has been detected.ERROR_POSSIBLE_DEADLOCK
    1132The base address or the file offset specified does not have theproper alignment.ERROR_MAPPED_ALIGNMENT
    1140An attempt to change the system power state was vetoed by anotherapplication or driver.ERROR_SET_POWER_STATE_VETOED
    1141The system BIOS failed an attempt to change the system power state.ERROR_SET_POWER_STATE_FAILED
    1142An attempt was made to create more links on a file than the filesystem supports.ERROR_TOO_MANY_LINKS
    1150The specified program requires a newer version of Windows.ERROR_OLD_WIN_VERSION
    1151The specified program is not a Windows or MS-DOS program.ERROR_APP_WRONG_OS
    1152Cannot start more than one instance of the specified program.ERROR_SINGLE_INSTANCE_APP
    1153The specified program was written for an earlier version of Windows.ERROR_RMODE_APP
    1154One of the library files needed to run this application is damaged.ERROR_INVALID_DLL
    1155No application is associated with the specified file for thisoperation.ERROR_NO_ASSOCIATION
    1156An error occurred in sending the command to the application.ERROR_DDE_FAIL
    1157One of the library files needed to run this application cannot befound.ERROR_DLL_NOT_FOUND
    1200The specified device name is invalid.ERROR_BAD_DEVICE
    1201The device is not currently connected but it is a rememberedconnection.ERROR_CONNECTION_UNAVAIL
    1202An attempt was made to remember a device that had previously beenremembered.ERROR_DEVICE_ALREADY_REMEMBERED
    1203No network provider accepted the given network path.ERROR_NO_NET_OR_BAD_PATH
    1204The specified network provider name is invalid.ERROR_BAD_PROVIDER
    1205Unable to open the network connection profile.ERROR_CANNOT_OPEN_PROFILE
    1206The network connection profile is corrupt.ERROR_BAD_PROFILE
    1207Cannot enumerate a noncontainer.ERROR_NOT_CONTAINER
    1208An extended error has occurred.ERROR_EXTENDED_ERROR
    1209The format of the specified group name is invalid.ERROR_INVALID_GROUPNAME
    1210The format of the specified computer name is invalid.ERROR_INVALID_COMPUTERNAME
    1211The format of the specified event name is invalid.ERROR_INVALID_EVENTNAME
    1212The format of the specified domain name is invalid.ERROR_INVALID_DOMAINNAME
    1213The format of the specified service name is invalid.ERROR_INVALID_SERVICENAME
    1214The format of the specified network name is invalid.ERROR_INVALID_NETNAME
    1215The format of the specified share name is invalid.ERROR_INVALID_SHARENAME
    1216The format of the specified password is invalid.ERROR_INVALID_PASSWORDNAME
    1217The format of the specified message name is invalid.ERROR_INVALID_MESSAGENAME
    1218The format of the specified message destination is invalid.ERROR_INVALID_MESSAGEDEST
    1219The credentials supplied conflict with an existing set ofcredentials.ERROR_SESSION_CREDENTIAL_CONFLICT
    1220An attempt was made to establish a session to a network server, butthere are already too many sessions established to that server.ERROR_REMOTE_SESSION_LIMIT_EXCEEDED
    1221The workgroup or domain name is already in use by another computer onthe network.ERROR_DUP_DOMAINNAME
    1222The network is not present or not started.ERROR_NO_NETWORK
    1223The operation was canceled by the user.ERROR_CANCELLED
    1224The requested operation cannot be performed on a file with auser-mapped section open.ERROR_USER_MAPPED_FILE
    1225The remote system refused the network connection.ERROR_CONNECTION_REFUSED
    1226The network connection was gracefully closed.ERROR_GRACEFUL_DISCONNECT
    1227The network transport endpoint already has an address associated withit.ERROR_ADDRESS_ALREADY_ASSOCIATED
    1228An address has not yet been associated with the network endpoint.ERROR_ADDRESS_NOT_ASSOCIATED
    1229An operation was attempted on a nonexistent network connection.ERROR_CONNECTION_INVALID
    1230An invalid operation was attempted on an active network connection.ERROR_CONNECTION_ACTIVE
    1231The remote network is not reachable by the transport.ERROR_NETWORK_UNREACHABLE
    1232The remote system is not reachable by the transport.ERROR_HOST_UNREACHABLE
    1233The remote system does not support the transport protocol.ERROR_PROTOCOL_UNREACHABLE
    1234No service is operating at the destination network endpoint on theremote system.ERROR_PORT_UNREACHABLE
    1235The request was aborted.ERROR_REQUEST_ABORTED
    1236The network connection was aborted by the local system.ERROR_CONNECTION_ABORTED
    1237The operation could not be completed. A retry should be performed.ERROR_RETRY
    1238A connection to the server could not be made because the limit on thenumber of concurrent connections for this account has been reached.ERROR_CONNECTION_COUNT_LIMIT
    1239Attempting to log in during an unauthorized time of day for thisaccount.ERROR_LOGIN_TIME_RESTRICTION
    1240The account is not authorized to log in from this station.ERROR_LOGIN_WKSTA_RESTRICTION
    1241The network address could not be used for the operation requested.ERROR_INCORRECT_ADDRESS
    1242The service is already registered.ERROR_ALREADY_REGISTERED
    1243The specified service does not exist.ERROR_SERVICE_NOT_FOUND
    1244The operation being requested was not performed because the user hasnot been authenticated.ERROR_NOT_AUTHENTICATED
    1245The operation being requested was not performed because the user hasnot logged on to the network. The specified service does not exist.ERROR_NOT_LOGGED_ON
    1246Caller to continue with work in progress.ERROR_CONTINUE
    1247An attempt was made to perform an initialization operation wheninitialization has already been completed.ERROR_ALREADY_INITIALIZED
    1248No more local devices.ERROR_NO_MORE_DEVICES
    1265The system detected a possible attempt to compromise security. Please ensurethat you can contact the server that authenticated you.ERROR_DOWNGRADE_DETECTED
    1300Not all privileges referenced are assigned to the caller.ERROR_NOT_ALL_ASSIGNED
    1301Some mapping between account names and security IDs was not done.ERROR_SOME_NOT_MAPPED
    1302No system quota limits are specifically set for this account.ERROR_NO_QUOTAS_FOR_ACCOUNT
    1303No encryption key is available. A well-known encryption key wasreturned.ERROR_LOCAL_USER_SESSION_KEY
    1304The password is too complex to be converted to a LAN Managerpassword. The LAN Manager password returned is a NULL string.ERROR_NULL_LM_PASSWORD
    1305The revision level is unknown.ERROR_UNKNOWN_REVISION
    1306Indicates two revision levels are incompatible.ERROR_REVISION_MISMATCH
    1307This security ID may not be assigned as the owner of this object.ERROR_INVALID_OWNER
    1308This security ID may not be assigned as the primary group of anobject.ERROR_INVALID_PRIMARY_GROUP
    1309An attempt has been made to operate on an impersonation token by athread that is not currently impersonating a client.ERROR_NO_IMPERSONATION_TOKEN
    1310The group may not be disabled.ERROR_CANT_DISABLE_MANDATORY
    1311There are currently no logon servers available to service the logonrequest.ERROR_NO_LOGON_SERVERS
    1312A specified logon session does not exist. It may already have beenterminated.ERROR_NO_SUCH_LOGON_SESSION
    1313A specified privilege does not exist.ERROR_NO_SUCH_PRIVILEGE
    1314A required privilege is not held by the client.ERROR_PRIVILEGE_NOT_HELD
    1315The name provided is not a properly formed account name.ERROR_INVALID_ACCOUNT_NAME
    1316The specified user already exists.ERROR_USER_EXISTS
    1317The specified user does not exist.ERROR_NO_SUCH_USER
    1318The specified group already exists.ERROR_GROUP_EXISTS
    1319The specified group does not exist.ERROR_NO_SUCH_GROUP
    1320Either the specified user account is already a member of thespecified group, or the specified group cannot be deleted because it contains a member.ERROR_MEMBER_IN_GROUP
    1321The specified user account is not a member of the specified groupaccount.ERROR_MEMBER_NOT_IN_GROUP
    1322The last remaining administration account cannot be disabled ordeleted.ERROR_LAST_ADMIN
    1323Unable to update the password. The value provided as the currentpassword is incorrect.ERROR_WRONG_PASSWORD
    1324Unable to update the password. The value provided for the newpassword contains values that are not allowed in passwords.ERROR_ILL_FORMED_PASSWORD
    1325Unable to update the password because a password update rule has beenviolated.ERROR_PASSWORD_RESTRICTION
    1326Logon failure: unknown user name or bad password.ERROR_LOGON_FAILURE
    1327Logon failure: user account restriction.ERROR_ACCOUNT_RESTRICTION
    1328Logon failure: account logon time restriction violation.ERROR_INVALID_LOGON_HOURS
    1329Logon failure: user not allowed to log on to this computer.ERROR_INVALID_WORKSTATION
    1330Logon failure: the specified account password has expired.ERROR_PASSWORD_EXPIRED
    1331Logon failure: account currently disabled.ERROR_ACCOUNT_DISABLED
    1332No mapping between account names and security IDs was done.ERROR_NONE_MAPPED
    1333Too many local user identifiers (LUIDs) were requested at one time.ERROR_TOO_MANY_LUIDS_REQUESTED
    1334No more local user identifiers (LUIDs) are available.ERROR_LUIDS_EXHAUSTED
    1335The subauthority part of a security ID is invalid for this particularuse.ERROR_INVALID_SUB_AUTHORITY
    1336The access control list (ACL) structure is invalid.ERROR_INVALID_ACL
    1337The security ID structure is invalid.ERROR_INVALID_SID
    1338The security descriptor structure is invalid.ERROR_INVALID_SECURITY_DESCR
    1340The inherited access control list (ACL) or access control entry (ACE)could not be built.ERROR_BAD_INHERITANCE_ACL
    1341The server is currently disabled.ERROR_SERVER_DISABLED
    1342The server is currently enabled.ERROR_SERVER_NOT_DISABLED
    1343The value provided was an invalid value for an identifier authority.ERROR_INVALID_ID_AUTHORITY
    1344No more memory is available for security information updates.ERROR_ALLOTTED_SPACE_EXCEEDED
    1345The specified attributes are invalid, or incompatible with theattributes for the group as a whole.ERROR_INVALID_GROUP_ATTRIBUTES
    1346Either a required impersonation level was not provided, or theprovided impersonation level is invalid.ERROR_BAD_IMPERSONATION_LEVEL
    1347Cannot open an anonymous level security token.ERROR_CANT_OPEN_ANONYMOUS
    1348The validation information class requested was invalid.ERROR_BAD_VALIDATION_CLASS
    1349The type of the token is inappropriate for its attempted use.ERROR_BAD_TOKEN_TYPE
    1350Unable to perform a security operation on an object that has noassociated security.ERROR_NO_SECURITY_ON_OBJECT
    1351Indicates a Windows NT Server could not be contacted or that objectswithin the domain are protected such that necessary information could not be retrieved.ERROR_CANT_ACCESS_DOMAIN_INFO
    1352The security account manager (SAM) or local security authority (LSA)server was in the wrong state to perform the security operation.ERROR_INVALID_SERVER_STATE
    1353The domain was in the wrong state to perform the security operation.ERROR_INVALID_DOMAIN_STATE
    1354This operation is only allowed for the Primary Domain Controller ofthe domain.ERROR_INVALID_DOMAIN_ROLE
    1355The specified domain did not exist.ERROR_NO_SUCH_DOMAIN
    1356The specified domain already exists.ERROR_DOMAIN_EXISTS
    1357An attempt was made to exceed the limit on the number of domains perserver.ERROR_DOMAIN_LIMIT_EXCEEDED
    1358Unable to complete the requested operation because of either acatastrophic media failure or a data structure corruption on the disk.ERROR_INTERNAL_DB_CORRUPTION
    1359The security account database contains an internal inconsistency.ERROR_INTERNAL_ERROR
    1360Generic access types were contained in an access mask which shouldalready be mapped to nongeneric types.ERROR_GENERIC_NOT_MAPPED
    1361A security descriptor is not in the right format (absolute orself-relative).ERROR_BAD_DESCRIPTOR_FORMAT
    1362The requested action is restricted for use by logon processes only.The calling process has not registered as a logon process.ERROR_NOT_LOGON_PROCESS
    1363Cannot start a new logon session with an ID that is already in use.ERROR_LOGON_SESSION_EXISTS
    1364A specified authentication package is unknown.ERROR_NO_SUCH_PACKAGE
    1365The logon session is not in a state that is consistent with therequested operation.ERROR_BAD_LOGON_SESSION_STATE
    1366The logon session ID is already in use.ERROR_LOGON_SESSION_COLLISION
    1367A logon request contained an invalid logon type value.ERROR_INVALID_LOGON_TYPE
    1368Unable to impersonate using a named pipe until data has been readfrom that pipe.ERROR_CANNOT_IMPERSONATE
    1369The transaction state of a registry subtree is incompatible with therequested operation.ERROR_RXACT_INVALID_STATE
    1370An internal security database corruption has been encountered.ERROR_RXACT_COMMIT_FAILURE
    1371Cannot perform this operation on built-in accounts.ERROR_SPECIAL_ACCOUNT
    1372Cannot perform this operation on this built-in special group.ERROR_SPECIAL_GROUP
    1373Cannot perform this operation on this built-in special user.ERROR_SPECIAL_USER
    1374The user cannot be removed from a group because the group iscurrently the user's primary group.ERROR_MEMBERS_PRIMARY_GROUP
    1375The token is already in use as a primary token.ERROR_TOKEN_ALREADY_IN_USE
    1376The specified local group does not exist.ERROR_NO_SUCH_ALIAS
    1377The specified account name is not a member of the local group.ERROR_MEMBER_NOT_IN_ALIAS
    1378The specified account name is already a member of the local group.ERROR_MEMBER_IN_ALIAS
    1379The specified local group already exists.ERROR_ALIAS_EXISTS
    1380Logon failure: the user has not been granted the requested logon typeat this computer.ERROR_LOGON_NOT_GRANTED
    1381The maximum number of secrets that may be stored in a single systemhas been exceeded.ERROR_TOO_MANY_SECRETS
    1382The length of a secret exceeds the maximum length allowed.ERROR_SECRET_TOO_LONG
    1383The local security authority database contains an internalinconsistency.ERROR_INTERNAL_DB_ERROR
    1384During a logon attempt, the user's security context accumulated toomany security IDs.ERROR_TOO_MANY_CONTEXT_IDS
    1385Logon failure: the user has not been granted the requested logon typeat this computer.ERROR_LOGON_TYPE_NOT_GRANTED
    1386A cross-encrypted password is necessary to change a user password.ERROR_NT_CROSS_ENCRYPTION_REQUIRED
    1387A new member could not be added to a local group because the memberdoes not exist.ERROR_NO_SUCH_MEMBER
    1388A new member could not be added to a local group because the memberhas the wrong account type.ERROR_INVALID_MEMBER
    1389Too many security IDs have been specified.ERROR_TOO_MANY_SIDS
    1390A cross-encrypted password is necessary to change this user password.ERROR_LM_CROSS_ENCRYPTION_REQUIRED
    1391Indicates an ACL contains no inheritable components.ERROR_NO_INHERITANCE
    1392The file or directory is corrupted and non-readable.ERROR_FILE_CORRUPT
    1393The disk structure is corrupted and non-readable.ERROR_DISK_CORRUPT
    1394There is no user session key for the specified logon session.ERROR_NO_USER_SESSION_KEY
    1395The service being accessed is licensed for a particular number ofconnections. No more connections can be made to the service at this time because there arealready as many connections as the service can accept.ERROR_LICENSE_QUOTA_EXCEEDED
    1398There is a time difference between the client and the server.ERROR_TIME_SKEW
    1400Invalid window handle.ERROR_INVALID_WINDOW_HANDLE
    1401Invalid menu handle.ERROR_INVALID_MENU_HANDLE
    1402Invalid cursor handle.ERROR_INVALID_CURSOR_HANDLE
    1403Invalid accelerator table handle.ERROR_INVALID_ACCEL_HANDLE
    1404Invalid hook handle.ERROR_INVALID_HOOK_HANDLE
    1405Invalid handle to a multiple-window position structure.ERROR_INVALID_DWP_HANDLE
    1406Cannot create a top-level child window.ERROR_TLW_WITH_WSCHILD
    1407Cannot find window class.ERROR_CANNOT_FIND_WND_CLASS
    1408Invalid window, it belongs to another thread.ERROR_WINDOW_OF_OTHER_THREAD
    1409Hot key is already registered.ERROR_HOTKEY_ALREADY_REGISTERED
    1410Class already exists.ERROR_CLASS_ALREADY_EXISTS
    1411Class does not exist.ERROR_CLASS_DOES_NOT_EXIST
    1412Class still has open windows.ERROR_CLASS_HAS_WINDOWS
    1413Invalid index.ERROR_INVALID_INDEX
    1414Invalid icon handle.ERROR_INVALID_ICON_HANDLE
    1415Using private DIALOG window words.ERROR_PRIVATE_DIALOG_INDEX
    1416The list box identifier was not found.ERROR_LISTBOX_ID_NOT_FOUND
    1417No wildcards were found.ERROR_NO_WILDCARD_CHARACTERS
    1418Thread does not have a clipboard open.ERROR_CLIPBOARD_NOT_OPEN
    1419Hot key is not registered.ERROR_HOTKEY_NOT_REGISTERED
    1420The window is not a valid dialog window.ERROR_WINDOW_NOT_DIALOG
    1421Control ID not found.ERROR_CONTROL_ID_NOT_FOUND
    1422Invalid message for a combo box because it does not have an editcontrol.ERROR_INVALID_COMBOBOX_MESSAGE
    1423The window is not a combo box.ERROR_WINDOW_NOT_COMBOBOX
    1424Height must be less than 256.ERROR_INVALID_EDIT_HEIGHT
    1425Invalid device context (DC) handle.ERROR_DC_NOT_FOUND
    1426Invalid hook procedure type.ERROR_INVALID_HOOK_FILTER
    1427Invalid hook procedure.ERROR_INVALID_FILTER_PROC
    1428Cannot set nonlocal hook without a module handle.ERROR_HOOK_NEEDS_HMOD
    1429This hook procedure can only be set globally.ERROR_GLOBAL_ONLY_HOOK
    1430The journal hook procedure is already installed.ERROR_JOURNAL_HOOK_SET
    1431The hook procedure is not installed.ERROR_HOOK_NOT_INSTALLED
    1432Invalid message for single-selection list box.ERROR_INVALID_LB_MESSAGE
    1433LB_SETCOUNT sent to non-lazy list box.ERROR_SETCOUNT_ON_BAD_LB
    1434This list box does not support tab stops.ERROR_LB_WITHOUT_TABSTOPS
    1435Cannot destroy object created by another thread.ERROR_DESTROY_OBJECT_OF_OTHER_THREAD
    1436Child windows cannot have menus.ERROR_CHILD_WINDOW_MENU
    1437The window does not have a system menu.ERROR_NO_SYSTEM_MENU
    1438Invalid message box style.ERROR_INVALID_MSGBOX_STYLE
    1439Invalid system-wide (SPI_*) parameter.ERROR_INVALID_SPI_VALUE
    1440Screen already locked.ERROR_SCREEN_ALREADY_LOCKED
    1441All handles to windows in a multiple-window position structure musthave the same parent.ERROR_HWNDS_HAVE_DIFF_PARENT
    1442The window is not a child window.ERROR_NOT_CHILD_WINDOW
    1443Invalid GW_* command.ERROR_INVALID_GW_COMMAND
    1444Invalid thread identifier.ERROR_INVALID_THREAD_ID
    1445Cannot process a message from a window that is not a multipledocument interface (MDI) window.ERROR_NON_MDICHILD_WINDOW
    1446Popup menu already active.ERROR_POPUP_ALREADY_ACTIVE
    1447The window does not have scroll bars.ERROR_NO_SCROLLBARS
    1448Scroll bar range cannot be greater than 0x7FFF.ERROR_INVALID_SCROLLBAR_RANGE
    1449Cannot show or remove the window in the way specified.ERROR_INVALID_SHOWWIN_COMMAND
    1450Insufficient system resources exist to complete the requestedservice.ERROR_NO_SYSTEM_RESOURCES
    1451Insufficient system resources exist to complete the requestedservice.ERROR_NONPAGED_SYSTEM_RESOURCES
    1452Insufficient system resources exist to complete the requestedservice.ERROR_PAGED_SYSTEM_RESOURCES
    1453Insufficient quota to complete the requested service.ERROR_WORKING_SET_QUOTA
    1454Insufficient quota to complete the requested service.ERROR_PAGEFILE_QUOTA
    1455The paging file is too small for this operation to complete.ERROR_COMMITMENT_LIMIT
    1456A menu item was not found.ERROR_MENU_ITEM_NOT_FOUND
    1457Invalid keyboard layout handle.ERROR_INVALID_KEYBOARD_HANDLE
    1458Hook type not allowed.ERROR_HOOK_TYPE_NOT_ALLOWED
    1459This operation requires an interactive window station.ERROR_REQUIRES_INTERACTIVE_WINDOWSTATION
    1460This operation returned because the time-out period expired.ERROR_TIMEOUT
    1500The event log file is corrupted.ERROR_EVENTLOG_FILE_CORRUPT
    1501No event log file could be opened, so the event logging service didnot start.ERROR_EVENTLOG_CANT_START
    1502The event log file is full.ERROR_LOG_FILE_FULL
    1503The event log file has changed between read operations.ERROR_EVENTLOG_FILE_CHANGED
    1700The string binding is invalid.RPC_S_INVALID_STRING_BINDING
    1701The binding handle is not the correct type.RPC_S_WRONG_KIND_OF_BINDING
    1702The binding handle is invalid.RPC_S_INVALID_BINDING
    1703The RPC protocol sequence is not supported.RPC_S_PROTSEQ_NOT_SUPPORTED
    1704The RPC protocol sequence is invalid.RPC_S_INVALID_RPC_PROTSEQ
    1705The string universal unique identifier (UUID) is invalid.RPC_S_INVALID_STRING_UUID
    1706The endpoint format is invalid.RPC_S_INVALID_ENDPOINT_FORMAT
    1707The network address is invalid.RPC_S_INVALID_NET_ADDR
    1708No endpoint was found.RPC_S_NO_ENDPOINT_FOUND
    1709The time-out value is invalid.RPC_S_INVALID_TIMEOUT
    1710The object universal unique identifier (UUID) was not found.RPC_S_OBJECT_NOT_FOUND
    1711The object universal unique identifier (UUID) has already beenregistered.RPC_S_ALREADY_REGISTERED
    1712The type universal unique identifier (UUID) has already beenregistered.RPC_S_TYPE_ALREADY_REGISTERED
    1713The RPC server is already listening.RPC_S_ALREADY_LISTENING
    1714No protocol sequences have been registered.RPC_S_NO_PROTSEQS_REGISTERED
    1715The RPC server is not listening.RPC_S_NOT_LISTENING
    1716The manager type is unknown.RPC_S_UNKNOWN_MGR_TYPE
    1717The interface is unknown.RPC_S_UNKNOWN_IF
    1718There are no bindings.RPC_S_NO_BINDINGS
    1719There are no protocol sequences.RPC_S_NO_PROTSEQS
    1720The endpoint cannot be created.RPC_S_CANT_CREATE_ENDPOINT
    1721Not enough resources are available to complete this operation.RPC_S_OUT_OF_RESOURCES
    1722The RPC server is unavailable.RPC_S_SERVER_UNAVAILABLE
    1723The RPC server is too busy to complete this operation.RPC_S_SERVER_TOO_BUSY
    1724The network options are invalid.RPC_S_INVALID_NETWORK_OPTIONS
    1725There is not a remote procedure call active in this thread.RPC_S_NO_CALL_ACTIVE
    1726The remote procedure call failed.RPC_S_CALL_FAILED
    1727The remote procedure call failed and did not execute.RPC_S_CALL_FAILED_DNE
    1728A remote procedure call (RPC) protocol error occurred.RPC_S_PROTOCOL_ERROR
    1730The transfer syntax is not supported by the RPC server.RPC_S_UNSUPPORTED_TRANS_SYN
    1732The universal unique identifier (UUID) type is not supported.RPC_S_UNSUPPORTED_TYPE
    1733The tag is invalid.RPC_S_INVALID_TAG
    1734The array bounds are invalid.RPC_S_INVALID_BOUND
    1735The binding does not contain an entry name.RPC_S_NO_ENTRY_NAME
    1736The name syntax is invalid.RPC_S_INVALID_NAME_SYNTAX
    1737The name syntax is not supported.RPC_S_UNSUPPORTED_NAME_SYNTAX
    1739No network address is available to use to construct a universalunique identifier (UUID).RPC_S_UUID_NO_ADDRESS
    1740The endpoint is a duplicate.RPC_S_DUPLICATE_ENDPOINT
    1741The authentication type is unknown.RPC_S_UNKNOWN_AUTHN_TYPE
    1742The maximum number of calls is too small.RPC_S_MAX_CALLS_TOO_SMALL
    1743The string is too long.RPC_S_STRING_TOO_LONG
    1744The RPC protocol sequence was not found.RPC_S_PROTSEQ_NOT_FOUND
    1745The procedure number is out of range.RPC_S_PROCNUM_OUT_OF_RANGE
    1746The binding does not contain any authentication information.RPC_S_BINDING_HAS_NO_AUTH
    1747The authentication service is unknown.RPC_S_UNKNOWN_AUTHN_SERVICE
    1748The authentication level is unknown.RPC_S_UNKNOWN_AUTHN_LEVEL
    1749The security context is invalid.RPC_S_INVALID_AUTH_IDENTITY
    1750The authorization service is unknown.RPC_S_UNKNOWN_AUTHZ_SERVICE
    1751The entry is invalid.EPT_S_INVALID_ENTRY
    1752The server endpoint cannot perform the operation.EPT_S_CANT_PERFORM_OP
    1753There are no more endpoints available from the endpoint mapper.EPT_S_NOT_REGISTERED
    1754No interfaces have been exported.RPC_S_NOTHING_TO_EXPORT
    1755The entry name is incomplete.RPC_S_INCOMPLETE_NAME
    1756The version option is invalid.RPC_S_INVALID_VERS_OPTION
    1757There are no more members.RPC_S_NO_MORE_MEMBERS
    1758There is nothing to unexport.RPC_S_NOT_ALL_OBJS_UNEXPORTED
    1759The interface was not found.RPC_S_INTERFACE_NOT_FOUND
    1760The entry already exists.RPC_S_ENTRY_ALREADY_EXISTS
    1761The entry is not found.RPC_S_ENTRY_NOT_FOUND
    1762The name service is unavailable.RPC_S_NAME_SERVICE_UNAVAILABLE
    1763The network address family is invalid.RPC_S_INVALID_NAF_ID
    1764The requested operation is not supported.RPC_S_CANNOT_SUPPORT
    1765No security context is available to allow impersonation.RPC_S_NO_CONTEXT_AVAILABLE
    1766An internal error occurred in a remote procedure call (RPC).RPC_S_INTERNAL_ERROR
    1767The RPC server attempted an integer division by zero.RPC_S_ZERO_DIVIDE
    1768An addressing error occurred in the RPC server.RPC_S_ADDRESS_ERROR
    1769A floating-point operation at the RPC server caused a division byzero.RPC_S_FP_DIV_ZERO
    1770A floating-point underflow occurred at the RPC server.RPC_S_FP_UNDERFLOW
    1771A floating-point overflow occurred at the RPC server.RPC_S_FP_OVERFLOW
    1772The list of RPC servers available for the binding of auto handles hasbeen exhausted.RPC_X_NO_MORE_ENTRIES
    1773Unable to open the character translation table file.RPC_X_SS_CHAR_TRANS_OPEN_FAIL
    1774The file containing the character translation table has fewer than512 bytes.RPC_X_SS_CHAR_TRANS_SHORT_FILE
    1775A null context handle was passed from the client to the host during aremote procedure call.RPC_X_SS_IN_NULL_CONTEXT
    1777The context handle changed during a remote procedure call.RPC_X_SS_CONTEXT_DAMAGED
    1778The binding handles passed to a remote procedure call do not match.RPC_X_SS_HANDLES_MISMATCH
    1779The stub is unable to get the remote procedure call handle.RPC_X_SS_CANNOT_GET_CALL_HANDLE
    1780A null reference pointer was passed to the stub.RPC_X_NULL_REF_POINTER
    1781The enumeration value is out of range.RPC_X_ENUM_VALUE_OUT_OF_RANGE
    1782The byte count is too small.RPC_X_BYTE_COUNT_TOO_SMALL
    1783The stub received bad data.RPC_X_BAD_STUB_DATA
    1784The supplied user buffer is not valid for the requested operation.ERROR_INVALID_USER_BUFFER
    1785The disk media is not recognized. It may not be formatted.ERROR_UNRECOGNIZED_MEDIA
    1786The workstation does not have a trust secret.ERROR_NO_TRUST_LSA_SECRET
    1787The SAM database on the Windows NT Server does not have a computeraccount for this workstation trust relationship.ERROR_NO_TRUST_SAM_ACCOUNT
    1788The trust relationship between the primary domain and the trusteddomain failed.ERROR_TRUSTED_DOMAIN_FAILURE
    1789The trust relationship between this workstation and the primarydomain failed.ERROR_TRUSTED_RELATIONSHIP_FAILURE
    1790The network logon failed.ERROR_TRUST_FAILURE
    1791A remote procedure call is already in progress for this thread.RPC_S_CALL_IN_PROGRESS
    1792An attempt was made to logon, but the network logon service was notstarted.ERROR_NETLOGON_NOT_STARTED
    1793The user's account has expired.ERROR_ACCOUNT_EXPIRED
    1794The redirector is in use and cannot be unloaded.ERROR_REDIRECTOR_HAS_OPEN_HANDLES
    1795The specified printer driver is already installed.ERROR_PRINTER_DRIVER_ALREADY_INSTALLED
    1796The specified port is unknown.ERROR_UNKNOWN_PORT
    1797The printer driver is unknown.ERROR_UNKNOWN_PRINTER_DRIVER
    1798The print processor is unknown.ERROR_UNKNOWN_PRINTPROCESSOR
    1799The specified separator file is invalid.ERROR_INVALID_SEPARATOR_FILE
    1800The specified priority is invalid.ERROR_INVALID_PRIORITY
    1801The printer name is invalid.ERROR_INVALID_PRINTER_NAME
    1802The printer already exists.ERROR_PRINTER_ALREADY_EXISTS
    1803The printer command is invalid.ERROR_INVALID_PRINTER_COMMAND
    1804The specified data type is invalid.ERROR_INVALID_DATATYPE
    1805The environment specified is invalid.ERROR_INVALID_ENVIRONMENT
    1806There are no more bindings.RPC_S_NO_MORE_BINDINGS
    1807The account used is an interdomain trust account. Use your globaluser account or local user account to access this server.ERROR_NOLOGON_INTERDOMAIN_TRUST_ACCOUNT
    1808The account used is a computer account. Use your global user accountor local user account to access this server.ERROR_NOLOGON_WORKSTATION_TRUST_ACCOUNT
    1809The account used is a server trust account. Use your global useraccount or local user account to access this server.ERROR_NOLOGON_SERVER_TRUST_ACCOUNT
    1810The name or security ID (SID) of the domain specified is inconsistentwith the trust information for that domain.ERROR_DOMAIN_TRUST_INCONSISTENT
    1811The server is in use and cannot be unloaded.ERROR_SERVER_HAS_OPEN_HANDLES
    1812The specified image file did not contain a resource section.ERROR_RESOURCE_DATA_NOT_FOUND
    1813The specified resource type cannot be found in the image file.ERROR_RESOURCE_TYPE_NOT_FOUND
    1814The specified resource name cannot be found in the image file.ERROR_RESOURCE_NAME_NOT_FOUND
    1815The specified resource language ID cannot be found in the image file.ERROR_RESOURCE_LANG_NOT_FOUND
    1816Not enough quota is available to process this command.ERROR_NOT_ENOUGH_QUOTA
    1817No interfaces have been registered.RPC_S_NO_INTERFACES
    1818The server was altered while processing this call.RPC_S_CALL_CANCELLED
    1819The binding handle does not contain all required information.RPC_S_BINDING_INCOMPLETE
    1820Communications failure.RPC_S_COMM_FAILURE
    1821The requested authentication level is not supported.RPC_S_UNSUPPORTED_AUTHN_LEVEL
    1822No principal name registered.RPC_S_NO_PRINC_NAME
    1823The error specified is not a valid Windows NT RPC error code.RPC_S_NOT_RPC_ERROR
    1824A UUID that is valid only on this computer has been allocated.RPC_S_UUID_LOCAL_ONLY
    1825A security package specific error occurred.RPC_S_SEC_PKG_ERROR
    1826Thread is not canceled.RPC_S_NOT_CANCELLED
    1827Invalid operation on the encoding/decoding handle.RPC_X_INVALID_ES_ACTION
    1828Incompatible version of the serializing package.RPC_X_WRONG_ES_VERSION
    1829Incompatible version of the RPC stub.RPC_X_WRONG_STUB_VERSION
    1830The idl pipe object is invalid or corrupted.RPC_X_INVALID_PIPE_OBJECT
    1831The operation is invalid for a given idl pipe object.RPC_X_INVALID_PIPE_OPERATION
    1832The idl pipe version is not supported.RPC_X_WRONG_PIPE_VERSION
    1898The group member was not found.RPC_S_GROUP_MEMBER_NOT_FOUND
    1899The endpoint mapper database could not be created.EPT_S_CANT_CREATE
    1900The object universal unique identifier (UUID) is the nil UUID.RPC_S_INVALID_OBJECT
    1901The specified time is invalid.ERROR_INVALID_TIME
    1902The specified form name is invalid.ERROR_INVALID_FORM_NAME
    1903The specified form size is invalid.ERROR_INVALID_FORM_SIZE
    1904The specified printer handle is already being waited onERROR_ALREADY_WAITING
    1905The specified printer has been deleted.ERROR_PRINTER_DELETED
    1906The state of the printer is invalid.ERROR_INVALID_PRINTER_STATE
    1907The user must change his password before he logs on the first time.ERROR_PASSWORD_MUST_CHANGE
    1908Could not find the domain controller for this domain.ERROR_DOMAIN_CONTROLLER_NOT_FOUND
    1909The referenced account is currently locked out and may not be loggedon to.ERROR_ACCOUNT_LOCKED_OUT
    1910The object exporter specified was not found.OR_INVALID_OXID
    1911The object specified was not found.OR_INVALID_OID
    1912The object resolver set specified was not found.OR_INVALID_SET
    1913Some data remains to be sent in the request buffer.RPC_S_SEND_INCOMPLETE
    2000The pixel format is invalid.ERROR_INVALID_PIXEL_FORMAT
    2001The specified driver is invalid.ERROR_BAD_DRIVER
    2002The window style or class attribute is invalid for this operation.ERROR_INVALID_WINDOW_STYLE
    2003The requested metafile operation is not supported.ERROR_METAFILE_NOT_SUPPORTED
    2004The requested transformation operation is not supported.ERROR_TRANSFORM_NOT_SUPPORTED
    2005The requested clipping operation is not supported.ERROR_CLIPPING_NOT_SUPPORTED
    2202The specified user name is invalid.ERROR_BAD_USERNAME
    2250This network connection does not exist.ERROR_NOT_CONNECTED
    2401This network connection has files open or requests pending.ERROR_OPEN_FILES
    2402Active connections still exist.ERROR_ACTIVE_CONNECTIONS
    2404The device is in use by an active process and cannot be disconnected.ERROR_DEVICE_IN_USE
    3000The specified print monitor is unknown.ERROR_UNKNOWN_PRINT_MONITOR
    3001The specified printer driver is currently in use.ERROR_PRINTER_DRIVER_IN_USE
    3002The spool file was not found.ERROR_SPOOL_FILE_NOT_FOUND
    3003A StartDocPrinter call was not issued.ERROR_SPL_NO_STARTDOC
    3004An AddJob call was not issued.ERROR_SPL_NO_ADDJOB
    3005The specified print processor has already been installed.ERROR_PRINT_PROCESSOR_ALREADY_INSTALLED
    3006The specified print monitor has already been installed.ERROR_PRINT_MONITOR_ALREADY_INSTALLED
    3007The specified print monitor does not have the required functions.ERROR_INVALID_PRINT_MONITOR
    3008The specified print monitor is currently in use.ERROR_PRINT_MONITOR_IN_USE
    3009The requested operation is not allowed when there are jobs queued tothe printer.ERROR_PRINTER_HAS_JOBS_QUEUED
    3010The requested operation is successful. Changes will not be effectiveuntil the system is rebooted.ERROR_SUCCESS_REBOOT_REQUIRED
    3011The requested operation is successful. Changes will not be effectiveuntil the service is restarted.ERROR_SUCCESS_RESTART_REQUIRED
    4000WINS encountered an error while processing the command.ERROR_WINS_INTERNAL
    4001The local WINS can not be deleted.ERROR_CAN_NOT_DEL_LOCAL_WINS
    4002The importation from the file failed.ERROR_STATIC_INIT
    4003The backup failed. Was a full backup done before?ERROR_INC_BACKUP
    4004The backup failed. Check the directory to which you are backing thedatabase.ERROR_FULL_BACKUP
    4005The name does not exist in the WINS database.ERROR_REC_NON_EXISTENT
    4006Replication with a nonconfigured partner is not allowed.ERROR_RPL_NOT_ALLOWED
    6118The list of servers for this workgroup is not currently availableERROR_NO_BROWSER_SERVERS_FOUND
    10053Connection aborted. (An established connection was aborted by the software in your host machine.)WSAECONNABORTED
    10054Connection reset by peer. (An existing connection was forcibly closed by the remote host)WSAECONNRESET
  2. Peter Schmitz

    Peter Schmitz Administrator Staff Member

    I just found an easy way to grab individual error messages, and figured I would share it here.

    In a command window, type:

    Code (text):

    NET HELPMSG <error_id>
    replacing <error_id> with the actual error number:


Share This Page

Users found this page by searching for:

  1. open reloc file