Prevent Windows 2012 Servers from rebooting after Windows Update

Peter Schmitz

Staff member
One would think that by default a server is configured not to automatically reboot after it installs updates. This is not the case, and I have encountered several cases where while I'm logged into a machine, it suddenly decides on its own that it's reboot time (Damn you Skynet!). Here's how to prevent that from happening on Windows 2012.

Sign on on the machine. Then, hold your Windows key and press 'R' to run a command.
In the popup box, type : 'gpedit.msc' (minus the quotes):


Then, expand "Local Computer Policy", drill down into "Computer Configuration", "Administrative Templates", "Windows Components", "Windows Update" (Screenshot below cropped to save some space):

The two settings you want to adjust are "Configure Automatic Updates" and "No auto-restart with logged on users for scheduled automatic updates". Let's start with the former. Double-click the entry in the right-hand side of the screen.

In the configuration screen, we now set the "Configure Automatic Updates" option to "Enabled" (which seems counter-intuitive seeing what we want to accomplish, but bear with me), and then change the "Configure automatic updating" drop-down box to use option 2: "Notify for download and notify for install":


Click "OK", and then proceed to enable the "No auto-restart with logged on users for scheduled automatic updates installations" in a similar fashion:


Click "OK", and you should be all good to go!